re = /g\.command (<#\d+>)\nhttps?:\/\/[a-z0-9.-]+\n.+/i
str = 'g.command <#123456790>
https://ex1am1m1ple.com
name bla bla
descropsadqwd qw dqw qdw
asd dqw wq dwq dwdwwd
wqdqwdqwidqwdjqwd qwdwq doijqoiw djq'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end