package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)g\.command (<#\d+>)\nhttps?:\/\/[a-z0-9.-]+\n.+`)
var str = `g.command <#123456790>
https://ex1am1m1ple.com
name bla bla
descropsadqwd qw dqw qdw
asd dqw wq dwq dwdwwd
wqdqwdqwidqwdjqwd qwdwq doijqoiw djq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}