use strict;
my $str = 'g.command <#123456790>
https://ex1am1m1ple.com
name bla bla
descropsadqwd qw dqw qdw
asd dqw wq dwq dwdwwd
wqdqwdqwidqwdjqwd qwdwq doijqoiw djq';
my $regex = qr/g\.command (<#\d+>)\nhttps?:\/\/[a-z0-9.-]+\n.+/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}