#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((in) )?(today|tomorrow|yesterday|sunday|monday|tuesday|wednesday|thursday|friday|saturday|(one|two|three|four) (hours|weeks|months|years))( ago)?( at (\d\d?:\d\d|\d\d?) ?(am|pm|AM|PM)?)?"
Local $sString = "today" & @CRLF & _
"today at 1pm, monday at 2am" & @CRLF & _
"tomorrow at 3PM, in two weeks at 4AM" & @CRLF & _
"four weeks ago at 12:34" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")