$re = '/((in) )?(today|tomorrow|yesterday|sunday|monday|tuesday|wednesday|thursday|friday|saturday|(one|two|three|four) (hours|weeks|months|years))( ago)?( at (\d\d?:\d\d|\d\d?) ?(am|pm|AM|PM)?)?/m';
$str = 'today
today at 1pm, monday at 2am
tomorrow at 3PM, in two weeks at 4AM
four weeks ago at 12:34
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);