// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((in) )?(today|tomorrow|yesterday|sunday|monday|tuesday|wednesday|thursday|friday|saturday|(one|two|three|four) (hours|weeks|months|years))( ago)?( at (\d\d?:\d\d|\d\d?) ?(am|pm|AM|PM)?)?").unwrap();
let string = "today
today at 1pm, monday at 2am
tomorrow at 3PM, in two weeks at 4AM
four weeks ago at 12:34
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}