package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((in) )?(today|tomorrow|yesterday|sunday|monday|tuesday|wednesday|thursday|friday|saturday|(one|two|three|four) (hours|weeks|months|years))( ago)?( at (\d\d?:\d\d|\d\d?) ?(am|pm|AM|PM)?)?`)
var str = `today
today at 1pm, monday at 2am
tomorrow at 3PM, in two weeks at 4AM
four weeks ago at 12:34
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}