using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((in) )?(today|tomorrow|yesterday|sunday|monday|tuesday|wednesday|thursday|friday|saturday|(one|two|three|four) (hours|weeks|months|years))( ago)?( at (\d\d?:\d\d|\d\d?) ?(am|pm|AM|PM)?)?";
string input = @"today
today at 1pm, monday at 2am
tomorrow at 3PM, in two weeks at 4AM
four weeks ago at 12:34
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}