using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\;)(?=[^""]|("")?)""?((?(1)[^""]*|[^\;""]*))""?(?=\;|$)";
string input = @"""Code"";City;Country/Region Code;County
01067;Dresden;DE;Sachsen
01067;""Dresden Friedrichstadt"";DE;Sachsen
01067;Dresden Innere Altstadt;DE;Sachsen
01069;Dresden;DE;Sachsen
01097;Dresden;DE;Sachsen
01099;Dresden;DE;Sachsen
01108;Dresden;DE;Sachsen";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}