const regex = /(?:^|\;)(?=[^"]|(")?)"?((?(1)[^"]*|[^\;"]*))"?(?=\;|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\;)(?=[^"]|(")?)"?((?(1)[^"]*|[^\\;"]*))"?(?=\\;|$)', 'gm')
const str = `"Code";City;Country/Region Code;County
01067;Dresden;DE;Sachsen
01067;"Dresden Friedrichstadt";DE;Sachsen
01067;Dresden Innere Altstadt;DE;Sachsen
01069;Dresden;DE;Sachsen
01097;Dresden;DE;Sachsen
01099;Dresden;DE;Sachsen
01108;Dresden;DE;Sachsen`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}