import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\;)(?=[^\"]|(\")?)\"?((?(1)[^\"]*|[^\\;\"]*))\"?(?=\\;|$)";
final String string = "\"Code\";City;Country/Region Code;County\n"
+ "01067;Dresden;DE;Sachsen\n"
+ "01067;\"Dresden Friedrichstadt\";DE;Sachsen\n"
+ "01067;Dresden Innere Altstadt;DE;Sachsen\n"
+ "01069;Dresden;DE;Sachsen\n"
+ "01097;Dresden;DE;Sachsen\n"
+ "01099;Dresden;DE;Sachsen\n"
+ "01108;Dresden;DE;Sachsen";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}