# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(android:layout_marginStart="(.*?)")(?:(?!layout_marginLeft).)*(?=\/>)/\1\n\t\tandroid:layout_marginLeft="\2"/gm;t' <<< "<androidx.constraintlayout.widget.Barrier
android:id=\"@+id/barrier6\"
android:layout_width=\"wrap_content\"
android:layout_height=\"wrap_content\"
android:layout_marginStart=\"12dp\"/>
<androidx.constraintlayout.widget.Barrier
android:id=\"@+id/barrier6\"
android:layout_width=\"wrap_content\"
android:layout_height=\"wrap_content\"
android:layout_marginStart=\"15px\"/>
<androidx.constraintlayout.widget.Barrier
android:id=\"@+id/barrier6\"
android:layout_width=\"wrap_content\"
android:layout_height=\"wrap_content\"
android:layout_marginStart=\"28em\"
android:layout_marginLeft=\"28em\"/>"