using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(android:layout_marginStart=""(.*?)"")(?:(?!layout_marginLeft).)*(?=/>)";
string substitution = @"\1\n\t\tandroid:layout_marginLeft=""\2""";
string input = @"<androidx.constraintlayout.widget.Barrier
android:id=""@+id/barrier6""
android:layout_width=""wrap_content""
android:layout_height=""wrap_content""
android:layout_marginStart=""12dp""/>
<androidx.constraintlayout.widget.Barrier
android:id=""@+id/barrier6""
android:layout_width=""wrap_content""
android:layout_height=""wrap_content""
android:layout_marginStart=""15px""/>
<androidx.constraintlayout.widget.Barrier
android:id=""@+id/barrier6""
android:layout_width=""wrap_content""
android:layout_height=""wrap_content""
android:layout_marginStart=""28em""
android:layout_marginLeft=""28em""/>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}