import re
regex = re.compile(r"(android:layout_marginStart=\"(.*?)\")(?:(?!layout_marginLeft).)*(?=/>)", flags=re.MULTILINE)
test_str = ("<androidx.constraintlayout.widget.Barrier\n"
" android:id=\"@+id/barrier6\"\n"
" android:layout_width=\"wrap_content\"\n"
" android:layout_height=\"wrap_content\"\n"
" android:layout_marginStart=\"12dp\"/>\n\n"
"<androidx.constraintlayout.widget.Barrier\n"
" android:id=\"@+id/barrier6\"\n"
" android:layout_width=\"wrap_content\"\n"
" android:layout_height=\"wrap_content\"\n"
" android:layout_marginStart=\"15px\"/>\n\n"
"<androidx.constraintlayout.widget.Barrier\n"
" android:id=\"@+id/barrier6\"\n"
" android:layout_width=\"wrap_content\"\n"
" android:layout_height=\"wrap_content\"\n"
" android:layout_marginStart=\"28em\"\n"
" android:layout_marginLeft=\"28em\"/>")
subst = "\\1\\n\\t\\tandroid:layout_marginLeft=\"\\2\""
result = regex.sub(subst, test_str)
if result:
print(result)