$re = '~(android:layout_marginStart="(.*?)")(?:(?!layout_marginLeft).)*(?=/>)~m';
$str = '<androidx.constraintlayout.widget.Barrier
android:id="@+id/barrier6"
android:layout_width="wrap_content"
android:layout_height="wrap_content"
android:layout_marginStart="12dp"/>
<androidx.constraintlayout.widget.Barrier
android:id="@+id/barrier6"
android:layout_width="wrap_content"
android:layout_height="wrap_content"
android:layout_marginStart="15px"/>
<androidx.constraintlayout.widget.Barrier
android:id="@+id/barrier6"
android:layout_width="wrap_content"
android:layout_height="wrap_content"
android:layout_marginStart="28em"
android:layout_marginLeft="28em"/>';
$subst = "\1\n\t\tandroid:layout_marginLeft=\"\2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;