const regex = new RegExp('(android:layout_marginStart="(.*?)")(?:(?!layout_marginLeft).)*(?=/>)', 'gm')
const str = `<androidx.constraintlayout.widget.Barrier
android:id="@+id/barrier6"
android:layout_width="wrap_content"
android:layout_height="wrap_content"
android:layout_marginStart="12dp"/>
<androidx.constraintlayout.widget.Barrier
android:id="@+id/barrier6"
android:layout_width="wrap_content"
android:layout_height="wrap_content"
android:layout_marginStart="15px"/>
<androidx.constraintlayout.widget.Barrier
android:id="@+id/barrier6"
android:layout_width="wrap_content"
android:layout_height="wrap_content"
android:layout_marginStart="28em"
android:layout_marginLeft="28em"/>`;
const subst = `\1\n\t\tandroid:layout_marginLeft="\2"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);