using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?=\s|$)";
string substitution = @"";
string input = @"First sentence. Second sentence contains a number 1.0 and more words. One more sentence.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}