$re = '/\.(?=\s|$)/m';
$str = 'First sentence. Second sentence contains a number 1.0 and more words. One more sentence.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;