import re
regex = re.compile(r"\.(?=\s|$)", flags=re.MULTILINE)
test_str = "First sentence. Second sentence contains a number 1.0 and more words. One more sentence."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)