use strict;
my $str = 'First sentence. Second sentence contains a number 1.0 and more words. One more sentence.';
my $regex = qr/\.(?=\s|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";