const regex = /\.(?=\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?=\\s|$)', 'gm')
const str = `First sentence. Second sentence contains a number 1.0 and more words. One more sentence.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);