#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9]+(?:-[a-z0-9]+)*$"
Local $sString = "slug" & @CRLF & _
"$lug" & @CRLF & _
"some-slug-example" & @CRLF & _
"some_slug" & @CRLF & _
"some-slug--" & @CRLF & _
"some7slug-example" & @CRLF & _
"-slug-" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// You can show origina post on albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")