// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9]+(?:-[a-z0-9]+)*$").unwrap();
let string = "slug
$lug
some-slug-example
some_slug
some-slug--
some7slug-example
-slug-
// You can show origina post on albertcolom.com/blog";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}