use strict;
my $str = 'slug
$lug
some-slug-example
some_slug
some-slug--
some7slug-example
-slug-
// You can show origina post on albertcolom.com/blog';
my $regex = qr/^[a-z0-9]+(?:-[a-z0-9]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}