re = /^[a-z0-9]+(?:-[a-z0-9]+)*$/m
str = 'slug
$lug
some-slug-example
some_slug
some-slug--
some7slug-example
-slug-
// You can show origina post on albertcolom.com/blog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end