package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]+(?:-[a-z0-9]+)*$`)
var str = `slug
$lug
some-slug-example
some_slug
some-slug--
some7slug-example
-slug-
// You can show origina post on albertcolom.com/blog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}