import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\?\\](?:(?!\\[/?\\?\\]).)*%empty%(?:(?!\\[\\?\\]).)*\\[/\\?]";
final String string = "[?]<h1>%empty%</h1>\n"
+ "<p>text</p>\n"
+ "[/?] \n"
+ "text \n"
+ "[?]<h1>%empty%</h1>\n"
+ "<p>text</p>\n"
+ "[/?] \n"
+ "text\n\n\n\n"
+ "[?]<h1>%!empty%</h1>\n"
+ "<p>text</p>\n"
+ "[/?] \n"
+ "text \n"
+ "[?][][/<h1>%empty%</h1>][][[[]]]\n"
+ "<p>text</p>\n"
+ "[/?] \n"
+ "[?]<h1>%empty%</h1>\n"
+ "<p>text</p>[?]\n"
+ "[/?] \n"
+ "text[?]<h1>%!empty%</h1>\n"
+ "<p>text</p>\n"
+ "[/?] ";
final String subst = "REPLACED";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}