import re
regex = re.compile(r"\[\?\](?:(?!\[/?\?\]).)*%empty%(?:(?!\[\?\]).)*\[/\?]", flags=re.MULTILINE | re.DOTALL)
test_str = ("[?]<h1>%empty%</h1>\n"
"<p>text</p>\n"
"[/?] \n"
"text \n"
"[?]<h1>%empty%</h1>\n"
"<p>text</p>\n"
"[/?] \n"
"text\n\n\n\n"
"[?]<h1>%!empty%</h1>\n"
"<p>text</p>\n"
"[/?] \n"
"text \n"
"[?][][/<h1>%empty%</h1>][][[[]]]\n"
"<p>text</p>\n"
"[/?] \n"
"[?]<h1>%empty%</h1>\n"
"<p>text</p>[?]\n"
"[/?] \n"
"text[?]<h1>%!empty%</h1>\n"
"<p>text</p>\n"
"[/?] ")
subst = "REPLACED"
result = regex.sub(subst, test_str)
if result:
print(result)