#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][a-z]+[,.'-]?(?: [A-Z][a-z]+[,.'-]?)*$"
Local $sString = "John Doe" & @CRLF & _
"Martin Luther King, Jr." & @CRLF & _
"Betty d'Angelo" & @CRLF & _
"Jonathon3" & @CRLF & _
"jane doe" & @CRLF & _
"Jane Doe" & @CRLF & _
"A.............." & @CRLF & _
"A, , ... " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")