using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z][a-z]+[,.'-]?(?: [A-Z][a-z]+[,.'-]?)*$";
string input = @"John Doe
Martin Luther King, Jr.
Betty d'Angelo
Jonathon3
jane doe
Jane Doe
A..............
A, , ...
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}