re = /^[A-Z][a-z]+[,.'-]?(?: [A-Z][a-z]+[,.'-]?)*$/m
str = 'John Doe
Martin Luther King, Jr.
Betty d\'Angelo
Jonathon3
jane doe
Jane Doe
A..............
A, , ...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end