$re = '/^[A-Z][a-z]+[,.\'-]?(?: [A-Z][a-z]+[,.\'-]?)*$/m';
$str = 'John Doe
Martin Luther King, Jr.
Betty d\'Angelo
Jonathon3
jane doe
Jane Doe
A..............
A, , ...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);