import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z][a-z]+[,.'-]?(?: [A-Z][a-z]+[,.'-]?)*$";
final String string = "John Doe\n"
+ "Martin Luther King, Jr.\n"
+ "Betty d'Angelo\n"
+ "Jonathon3\n"
+ "jane doe\n"
+ "Jane Doe\n"
+ "A..............\n"
+ "A, , ... \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}