#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Bid\/Ask<\/TD>)[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(?=Low\/High<\/TD>)[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(\d{2}\.\d{2})"
Local $sString = " <TR class="spot" bgColor='#f1f1f1'>" & @CRLF & _
" <TD>Bid/Ask</TD> <TD" & @CRLF & _
" align='middle' ><font" & @CRLF & _
" color=''>15.73</font></TD>" & @CRLF & _
" <TD align='middle' > </TD>" & @CRLF & _
" <TD align='middle' ><font" & @CRLF & _
" color=''>15.83</font></TD>" & @CRLF & _
" </TR>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <TR class="spot" bgColor=''>" & @CRLF & _
" <TD>Low/High</TD> <TD" & @CRLF & _
" align='middle' ><font" & @CRLF & _
" color=''>15.51</font></TD>" & @CRLF & _
" <TD align='middle' > </TD>" & @CRLF & _
" <TD align='middle' ><font" & @CRLF & _
" color=''>15.86</font></TD>" & @CRLF & _
" </TR>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")