const regex = /(?<=Bid\/Ask<\/TD>)[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(?=Low\/High<\/TD>)[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(\d{2}\.\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Bid\\\/Ask<\\\/TD>)[\\s\\S]*?(\\d{2}\\.\\d{2})[\\s\\S]*?(\\d{2}\\.\\d{2})[\\s\\S]*?(?=Low\\\/High<\\\/TD>)[\\s\\S]*?(\\d{2}\\.\\d{2})[\\s\\S]*?(\\d{2}\\.\\d{2})', 'gm')
const str = ` <TR class="spot" bgColor='#f1f1f1'>
<TD>Bid/Ask</TD> <TD
align='middle' ><font
color=''>15.73</font></TD>
<TD align='middle' > </TD>
<TD align='middle' ><font
color=''>15.83</font></TD>
</TR>
<TR class="spot" bgColor=''>
<TD>Low/High</TD> <TD
align='middle' ><font
color=''>15.51</font></TD>
<TD align='middle' > </TD>
<TD align='middle' ><font
color=''>15.86</font></TD>
</TR>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}