import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Bid\\/Ask<\\/TD>)[\\s\\S]*?(\\d{2}\\.\\d{2})[\\s\\S]*?(\\d{2}\\.\\d{2})[\\s\\S]*?(?=Low\\/High<\\/TD>)[\\s\\S]*?(\\d{2}\\.\\d{2})[\\s\\S]*?(\\d{2}\\.\\d{2})";
final String string = " <TR class=\"spot\" bgColor='#f1f1f1'>\n"
+ " <TD>Bid/Ask</TD> <TD\n"
+ " align='middle' ><font\n"
+ " color=''>15.73</font></TD>\n"
+ " <TD align='middle' > </TD>\n"
+ " <TD align='middle' ><font\n"
+ " color=''>15.83</font></TD>\n"
+ " </TR>\n"
+ " \n\n\n"
+ " <TR class=\"spot\" bgColor=''>\n"
+ " <TD>Low/High</TD> <TD\n"
+ " align='middle' ><font\n"
+ " color=''>15.51</font></TD>\n"
+ " <TD align='middle' > </TD>\n"
+ " <TD align='middle' ><font\n"
+ " color=''>15.86</font></TD>\n"
+ " </TR>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}