import Foundation
let pattern = #"(?<=Bid\/Ask<\/TD>)[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(?=Low\/High<\/TD>)[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(\d{2}\.\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<TR class="spot" bgColor='#f1f1f1'>
<TD>Bid/Ask</TD> <TD
align='middle' ><font
color=''>15.73</font></TD>
<TD align='middle' > </TD>
<TD align='middle' ><font
color=''>15.83</font></TD>
</TR>
<TR class="spot" bgColor=''>
<TD>Low/High</TD> <TD
align='middle' ><font
color=''>15.51</font></TD>
<TD align='middle' > </TD>
<TD align='middle' ><font
color=''>15.86</font></TD>
</TR>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)