# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=Bid\/Ask<\/TD>)[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(?=Low\/High<\/TD>)[\s\S]*?(\d{2}\.\d{2})[\s\S]*?(\d{2}\.\d{2})"
test_str = (" <TR class=\"spot\" bgColor='#f1f1f1'>\n"
" <TD>Bid/Ask</TD> <TD\n"
" align='middle' ><font\n"
" color=''>15.73</font></TD>\n"
" <TD align='middle' > </TD>\n"
" <TD align='middle' ><font\n"
" color=''>15.83</font></TD>\n"
" </TR>\n"
" \n\n\n"
" <TR class=\"spot\" bgColor=''>\n"
" <TD>Low/High</TD> <TD\n"
" align='middle' ><font\n"
" color=''>15.51</font></TD>\n"
" <TD align='middle' > </TD>\n"
" <TD align='middle' ><font\n"
" color=''>15.86</font></TD>\n"
" </TR>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.