#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)\b[А-ЯЁа-яё]*[À-ž][А-ЯЁа-яё]*\b"
Local $sString = "страницы</title>" & @CRLF & _
"" & @CRLF & _
"words like “übermäßig” or “Mäuseöhrchen”. We’re here to bring some clarity:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")