import re
regex = re.compile(r"\b[А-ЯЁа-яё]*[À-ž][А-ЯЁа-яё]*\b", flags=re.MULTILINE)
test_str = ("страницы</title>\n\n"
"words like “übermäßig” or “Mäuseöhrchen”. We’re here to bring some clarity:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")