$re = '/\b[А-ЯЁа-яё]*[À-ž][А-ЯЁа-яё]*\b/mU';
$str = 'страницы</title>
words like “übermäßig” or “Mäuseöhrchen”. We’re here to bring some clarity:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);