// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mU)\b[А-ЯЁа-яё]*[À-ž][А-ЯЁа-яё]*\b").unwrap();
let string = "страницы</title>
words like “übermäßig” or “Mäuseöhrchen”. We’re here to bring some clarity:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}