const regex = new RegExp('\\b[А-ЯЁа-яё]*[À-ž][А-ЯЁа-яё]*\\b', 'gm')
const str = `страницы</title>
words like “übermäßig” or “Mäuseöhrchen”. We’re here to bring some clarity:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}