#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Hex Nut(?!.*\bNylon\b).*$"
Local $sString = "Hex Nut M16x1.5 Nylon 9121600-HI Carbon Steel MF" & @CRLF & _
"Hex Nut 5/8 9161590 Carbon Steel UNF 9161590" & @CRLF & _
"Hex Nut 1/2 9141270 Carbon Steel UNF 9141270" & @CRLF & _
"Hex Nut M20x1.5 9122000-HI Carbon Steel MF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")