import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Hex Nut(?!.*\\bNylon\\b).*$";
final String string = "Hex Nut M16x1.5 Nylon 9121600-HI Carbon Steel MF\n"
+ "Hex Nut 5/8 9161590 Carbon Steel UNF 9161590\n"
+ "Hex Nut 1/2 9141270 Carbon Steel UNF 9141270\n"
+ "Hex Nut M20x1.5 9122000-HI Carbon Steel MF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}