import Foundation
let pattern = #"^Hex Nut(?!.*\bNylon\b).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hex Nut M16x1.5 Nylon 9121600-HI Carbon Steel MF
Hex Nut 5/8 9161590 Carbon Steel UNF 9161590
Hex Nut 1/2 9141270 Carbon Steel UNF 9141270
Hex Nut M20x1.5 9122000-HI Carbon Steel MF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)