const regex = /^Hex Nut(?!.*\bNylon\b).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Hex Nut(?!.*\\bNylon\\b).*$', 'gm')
const str = `Hex Nut M16x1.5 Nylon 9121600-HI Carbon Steel MF
Hex Nut 5/8 9161590 Carbon Steel UNF 9161590
Hex Nut 1/2 9141270 Carbon Steel UNF 9141270
Hex Nut M20x1.5 9122000-HI Carbon Steel MF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}