re = /^Hex Nut(?!.*\bNylon\b).*$/m
str = 'Hex Nut M16x1.5 Nylon 9121600-HI Carbon Steel MF
Hex Nut 5/8 9161590 Carbon Steel UNF 9161590
Hex Nut 1/2 9141270 Carbon Steel UNF 9141270
Hex Nut M20x1.5 9122000-HI Carbon Steel MF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end