#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\buser\s+\S+\s+pswd\s+(\d+)"
Local $sString = "user stuff here 5" & @CRLF & _
"user banana1 pswd 4 " & @CRLF & _
"user lemon2 pswd 5" & @CRLF & _
"mumbo jumbo 12333 3" & @CRLF & _
"user h3lp pswd 8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")