re = /\buser\s+\S+\s+pswd\s+(\d+)/m
str = 'user stuff here 5
user banana1 pswd 4
user lemon2 pswd 5
mumbo jumbo 12333 3
user h3lp pswd 8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end